【python 错误解决】报错信息ImportError: /lib64/libstdc++.so.6: version `CXXABI_1.3.9

Linux上运行“main.py”文件,报错信息:

ImportError: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found 
(required by anaconda3/lib/python3.6/site-packages/scipy/sparse/_sparsetools.cpython-36m-x86_64-linux-gnu.so)

原因:gcc动态库版本过老

最简单的方案:不需要Root权限

 vi  ~/.bash_profile
LD_LIBRARY_PATH=/opt/anaconda3/lib:$LD_LIBRARY_PATH     
export LD_LIBRARY_PATH
$ source  ~/.bash_profile

在文件中添加如下代码
将anaconda3库文件路径添加到系统的库文件路径中

查看版本:

strings /opt/anaconda3/lib/libstdc++.so.6 | grep 'CXXABI'
已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页