【maven 错误解决】@Override is not allowed when implement interface method

Intellij IDEA,有时候 @Override却显红编译不通过。

解决方法:

由于我的项目是maven类型项目,所以在pox.xml的标签中添加如下代码,即可解决问题。

<build>
        <plugins>
            <!-- 编码和编译和JDK版本 -->
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>2.3.2</version>
                <configuration>
                    <source>1.7</source>
                    <target>1.7</target>
                    <encoding>utf8</encoding>
                </configuration>
            </plugin>
        </plugins>
    </build>
已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页